This incident has been resolved and all devices continues to operate normally.
Posted Nov 01, 2025 - 22:09 PDT
Update
A small number of vehicles with Getac ZX70 devices exhibited real-time tracking issues between 6:15 and 6:50 pm Pacific time. We implemented corrective measures at 6:50, and all vehicles and devices are operating normally at this time. We expect normal operations to continue throughout the remainder of the evening, but will continue monitoring for any exceptions.
Posted Nov 01, 2025 - 19:40 PDT
Monitoring
In anticipation of the Daylight Savings Time change tonight, we are proactively monitoring the performance of in-vehicle systems. Some Getac ZX70 model tablet devices may be affected by a manufacturer-level issue that causes irregularities in tracking due to their interpretation of the time change. This may result in sporadic tracking on vehicles with ZX70 model tablets beginning around 7:00 pm Pacific time (2:00 am UTC). Onboard functionality such as automated announcements will continue functioning normally.
Our team is prepared to implement corrective measures immediately should the manufacturer-related issue become apparent this evening.
Vehicles running the newer GMV Hub, T800 or consumer-grade tablets, or with basic tracking through CalAmp or Cradlepoint devices will not be impacted.
Devices is states where the time does not change will not be impacted.
At this time, all systems and devices are operating normally. We will provide updates here as they become relevant.